Powered by ZigaForm version 3.9.8.9.5

Чтение xml 1с — рассматриваем на примере

XML – это расширяемый язык разметки, широко применяющийся в 1С для обмена данными между конфигурациями и между другими внешними источниками данных. Предлагаем рассмотреть два варианта работы с xml 1С -  средствами внутреннего языка и средствами внутреннего языка с использованием XDTO пакетов.
получить бесплатную консультацию

XML – это расширяемый язык разметки, широко применяющийся в 1С для обмена данными между конфигурациями и между другими внешними источниками данных. Предлагаем рассмотреть два варианта работы с xml 1С —  средствами внутреннего языка и средствами внутреннего языка с использованием XDTO пакетов.

Чтение файла XML средствами внутреннего языка 1С

Создадим новый объект: ЧтениеXML. Он позволяет читать сообщения. Далее привожу простейший код, показывающий принцип чтения и разборки XML файла. Пояснения буду приводить в виде комментариев, чтобы не разрывать код на куски и его можно было скопировать для дальнейшего использования.

 

ЧтениеXML = Новый ЧтениеXML;

ЧтениеXML.ОткрытьФайл("d:\Temp\Test.XML");  //Открываем файл

Пока ЧтениеXML.Прочитать() Цикл  //Цикл по структуре

Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда  //Определяем начало элемента

Пока ЧтениеXML.ПрочитатьАтрибут() Цикл

//Внутри элемента считываем атрибуты

КонецЦикла;

ИначеЕсли ЧтениеXML.ТипУзла=ТипУзлаXML.Текст Тогда

//Если это текст, читаем текст

ИначеЕсли ЧтениеXML.ТипУзла=ТипУзлаXML.КонецЭлемента Тогда

//Определяем дальнейшие действия

КонецЕсли ;

КонецЦикла;

Таким образом, зная структуру файла, можно его разобрать «по полочкам» в программе 1С.

Запись данных из 1C в XML

Так же создадим объект ЗаписьXML.

 

ЗаписьXML = Новый ЗаписьXML;

ЗаписьXML.ОткрытьФайл("d:\Temp\Test.XML", "UTF-8"); //Открываем файл для записи, указываем кодировку

ЗаписьXML.ЗаписатьОбъявлениеXML();  // Записываем объявление XML

ЗаписьXML.ЗаписатьНачалоЭлемента("Организации"); // Начало элемента Организации

Выборка = Справочники.Организации.Выбрать();

Пока Выборка.Следующий() Цикл  // Начинаем выгружать организации

ЗаписьXML.ЗаписатьНачалоЭлемента("Организация"); // Начало элемента Организация

ЗаписьXML.ЗаписатьАтрибут("Код",Строка(Выборка.Код));

ЗаписьXML.ЗаписатьАтрибут("Наименование",Строка(Выборка.Наименование));

ЗаписьXML.ЗаписатьКонецЭлемента(); // Конец элемента Организация

КонецЦикла;

ЗаписьXML.ЗаписатьКонецЭлемента(); // Конец элемента Организации

Таким образом мы выгрузим код и наименование всех организаций из справочника 1С «Организации».

Выгрузка из 1C в XML с помощью XDTO-пакетов

В 1С предприятии существует такой объект метаданных, как XDTO-пакеты. Они служат для обмена данными в формате XML.

XDTO-пакет позволяет создать структуру, по которой потом пойдет выгрузка данных.

Теперь, определив структуру (ее, кстати, можно загрузить из файла), мы можем смело сформировать файл:

МойXML = Новый ЗаписьXML;

ПараметрыЗаписиXML = Новый ПараметрыЗаписиXML("UTF-8", "1.0", Ложь);

МойXML.ОткрытьФайл("d:\Temp\Test.XML",  ПараметрыЗаписиXML);

МойXML.ЗаписатьОбъявлениеXML();

ТипОбъектаАктивыВСистеме = ФабрикаXDTO.Тип("www.primer.ru/assets", "АктивыВСистеме");

ОбъектАктивыВСистеме = ФабрикаXDTO.Создать(ТипОбъектаАктивыВСистеме);

ОбъектАктивыВСистеме.ДатаВыгрузки = ТекущаяДата();

ТипОбъектаАктивы = ФабрикаXDTO.Тип("www.primer.ru/assets", "Активы");

ОбъектАктивы = ФабрикаXDTO.Создать(ТипОбъектаАктивы);

ОбъектАктивыВСистеме.Добавить(ФормаXML.Элемент, "www.primer.ru/assets", "Активы", ОбъектАктивы);

ТипОбъектаАктив = ФабрикаXDTO.Тип("www.primer.ru/assets", "Актив");

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

ОбъектАктив = ФабрикаXDTO.Создать(ТипОбъектаАктив);

ОбъектАктив.Наименование = ВыборкаДетальныеЗаписи.Наименование;

ОбъектАктив.ISIN = ВыборкаДетальныеЗаписи.ISIN;

ОбъектАктивы.Актив.Добавить(ОбъектАктив);

КонецЦикла;

ФабрикаXDTO.ЗаписатьXML(МойXML, ОбъектАктивыВСистеме);

МойXML.Закрыть();

Вот так, определив заранее схему, можно создать файл любой сложности.

 

Как оптимизировать работу с 1С?

Сделать это можно двумя основными способами:

  • Иметь в штате квалифицированных специалистов, которые имеют достаточную компетенцию для решения основных вопросов.

  • Обратиться за сопровождением 1С к сторонним специалистам.

Почему клиенты обращаются именно к нам?

  • Мы предлагаем не только внедрение, настройку и сопровождение, но и разработку под 1С, которая позволит оптимизировать ваши бизнес-процессы.

  • На вас работает не один человек, а целая команда. Вы не зависите от того, захочет ли специалист пойти в отпуск или взять больничный.

  • Вам не нужно оплачивать больничные, отпускные и готовить рабочее место для нового сотрудника.

  • Среди наших сотрудников не только специалисты 1С, но и опытные бухгалтера и юристы, поэтому мы подходим всесторонне к вопросу документооборота и отчетности.

  • Мы выстраиваем взаимодействие с клиентами так, чтобы вам удобно было оперативно обратиться по любому вопросу.

Позвоните по номеру телефона, указанному на сайте или заполните форму обратной связи, чтобы мы могли сориентировать по стоимости и рассказать, как начать сотрудничество.

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (1 оценок, среднее: 5,00 из 5)
Загрузка...

Хочу
оптимизировать
расходы

ООО "ПРОГРАММЫ 93"

Адрес нашего офиса:

г. Москва, Кусковская улица, д. 37/60

Телефоны:

+7 (499) 455-09-91

info@programs93.ru

Часы работы:

ПН - ВСК, 09:00 - 18:00

Заказать обратный звонок

Выберите свой тариф

1 час

  • Доработка 1С
  • Настройка 1С
  • Обучение 1С
  • Обслуживание 1С
  • Обновление 1С
  • Переход на новую программу 1С
  • Загрузка и перенос данных в 1С
  • Размещение 1С в облаке

Итого:

2000

Заказать

2 часа

  • Доработка 1С
  • Настройка 1С
  • Обучение 1С
  • Обслуживание 1С
  • Обновление 1С
  • Переход на новую программу 1С
  • Загрузка и перенос данных в 1С
  • Размещение 1С в облаке

Итого:

3000

Заказать

5 часов

  • Доработка 1С
  • Настройка 1С
  • Обучение 1С
  • Обслуживание 1С
  • Обновление 1С
  • Переход на новую программу 1С
  • Загрузка и перенос данных в 1С
  • Размещение 1С в облаке

Итого:

7000

Заказать

Индивидуальный тариф

Оставьте заявку, и мы разработаем индивидуальный тариф с учетом потребностей вашей компании!

Чтение xml 1с — рассматриваем на примере

XML – это расширяемый язык разметки, широко применяющийся в 1С для обмена данными между конфигурациями и между другими внешними источниками данных. Предлагаем рассмотреть два варианта работы с xml 1С -  средствами внутреннего языка и средствами внутреннего языка с использованием XDTO пакетов.

Веб-сервисы 1С: создание и публикация

Web сервисы 1С позволяют запускать некоторые функции 1С снаружи базы 1С, в том числе из других программ или других баз 1С. Без лишних рассуждений о том, кому и зачем это нужно, предлагаем сразу узнать как их создавать и опубликовывать. 

Работа с пользователями 1С: добавление, блокировка, удаление

Рассказываем про все основные действия с пользователями в 1С - от добавления нового пользователя до его блокировки и удаления. Мы рассмотрим разные режимы на конкретном примере, чтобы подать информацию максимально доступно.

Контакты

ООО "ПРОГРАММЫ 93"

Адрес нашего офиса:

г. Москва, Кусковская улица, д. 37/60

Телефоны:

+7 (499) 455-09-91

info@programs93.ru

Часы работы:

ПН - ВСК, 09:00 - 18:00

Заказать обратный звонок